08/17/12: MESS by mikedubya, | Category: General, Misc Topics | 5 comments - (Comments are closed)

MESS

Does anyone know of a direct link to get the latest MESS emulator. I tried following the MESS page and arrive to sendspace, set up an account, (a free one), it made me download ilivid and I still tried. This ilivid changed my homepage and put an unwanted toolbar on my browser. When finally I did manage to download it, the exe wouldn’t run and screwed up my browser such that I had to reboot my pc. I’ll pay for the emulator if that’s what this is all about. Until MESS makes it easier to download, I’ll stick with my real COCO.

This post was submitted by mikedubya.

5 comments to MESS

  • Robert Gault

    The sendspace link works for me. I unchecked the “use special accelerator” and got directly to the binary zip file.

    There are other links. If you use Windows systems and want the GUI, use the following link.
    http://messui.the-chronicles.org/

  • Thanks for the links Robert and Zephyr. I was able to get and unzip the MESS program without having to download weather bug and other assorted things. The problem I have now is that although I do have a bios file placed exactly as the DOCS say they should be…the coco3.rom and disk11.rom are not recognized and I get an error message about the config.txt and mess.ini configs. Interestingly enough when I click on the roms they do fire up in the coco3 dos. But how does one add a hard drive, (as written earlier the MESS64 or MESSUi64 I get that error message), as such it is unusable until I can figure out how to make them work. I checked the MESSUI.ini and everything looks OK as far as I can tell. MESS might be the best thing since jelly beans but right now turning on my real COCO3 is much easier. Again thanks for the help, but I don’t think I have the expertice to make it work, I’m a retired meteorologist and not software engineer.

  • RetroRick1974

    I never managed to get MESS running with CoCo 3 emulation unless the ROMs are in a COCO3.ZIP file. You then have it recognize the ROM files by selecting “Audit all systems” from the File menu in the GUI. Then, you close the MESS program and start it up again. This works for v1.06 of the emulator, but I honestly don’t use the newer MESS versions; I abandoned newer versions of MESS after trying out VCC.

    - RetroRick.

  • Robert Gault

    The details are important. It does not help to say “I did what the DOCS say” because we won’t know what you really did. :)

    To run MESS it is necessary to have the correct directory tree. Pick some directory (probably labeled MESS) and have at a minimum the following sub-directories: cfg, hash, ini, and roms. The roms directory for Coco use will have the following sub-directories: coco, cocoe, coco2, coco2b, coco3, coco3h, and coco3p. Each of these directories contains the required ROM images.
    For a Coco3, the default ROMs are: coco3.rom and disk11.rom.

    Are you trying to use a hard drive (.vhd) under Basic or OS-9? If it is Basic, you must either replace the stock disk11.rom with an RGBDOS variant or include an extra disk rom RGBDOS.rom installed in the CoCo Cartridge Slot.
    You probably will find the messui.exe easier to set up than mess.exe regards mounting disk images or accessory ROM images.

    Trouble shooting will probably be easier by direct email rather than on this site.